Outage affecting our Services
Incident Report for Landbot
Resolved
The incident has been resolved.
Posted Mar 03, 2021 - 17:06 CET
Investigating
We are experiencing an outage affecting our Services. We are currently investigating the issue.
Posted Mar 03, 2021 - 17:02 CET
This incident affected: Platform (Builder, Chats).